{"action":"Upgrade rust-pgp to 0.14.2-1 or later.","affected":[{"fixed":"0.14.2-1","introduced":"0"}],"component":"rust-pgp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.14.2-1"],"id":"tcs_01M5NMEK56Z9ENZB92VR6C1V2N","modified_at":"2026-09-15T09:03:15.295006669Z","published_at":"2024-12-05T16:15:26.393Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-53857","https://security-tracker.debian.org/tracker/CVE-2024-53857"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-53857#Debian:14/rust-pgp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-53857"}],"summary":"rPGP is a pure Rust implementation of OpenPGP. Prior to 0.14.1, rPGP allows attackers to trigger resource exhaustion vulnerabilities in rpgp by providing crafted messages. This affects general message"}