{"action":"Upgrade ppp to 2.5.2-1+1 or later.","affected":[{"fixed":"2.5.2-1+1","introduced":"0"}],"component":"ppp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.5.2-1+1"],"id":"tcs_01M5NMNK3C9Y6CT8YEKYDX8VWT","modified_at":"2026-11-02T12:03:11.683034427Z","published_at":"2025-04-22T01:15:17.270Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-58250","https://security-tracker.debian.org/tracker/CVE-2024-58250"],"severity":{"label":"critical","score":9.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-58250#Debian:13/ppp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-58250"}],"summary":"The passprompt plugin in pppd in ppp before 2.5.2 mishandles privileges."}