{"action":"Upgrade setuptools to 66.1.1-1+deb12u1 or later.","affected":[{"fixed":"66.1.1-1+deb12u1","introduced":"0"}],"component":"setuptools","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["66.1.1-1+deb12u1"],"id":"tcs_01M5NMP7PP75YNJGT52MV6Q0YB","modified_at":"2026-09-15T09:03:11.879332925Z","published_at":"2024-07-15T01:15:01.730Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2024-6345","https://security-tracker.debian.org/tracker/CVE-2024-6345"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2024-6345","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2024-6345"}],"summary":"A vulnerability in the package_index module of pypa/setuptools versions up to 69.1.1 allows for remote code execution via its download functions. These functions, which are used to download packages f"}