{"action":"Upgrade rustc to 1.89.0+dfsg1-1 or later.","affected":[{"fixed":"1.89.0+dfsg1-1","introduced":"0"}],"component":"rustc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.89.0+dfsg1-1"],"id":"tcs_01M5NMVE0XX2ARM8T4KJ1GBS18","modified_at":"2026-10-10T09:47:33.109716461Z","published_at":"2025-10-01T17:15:38.553Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-11233","https://security-tracker.debian.org/tracker/CVE-2025-11233"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-11233","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-11233"}],"summary":"Starting from Rust 1.87.0 and before Rust 1.89.0, the tier 3 Cygwin target (`x86_64-pc-cygwin`) didn't correctly handle path separators, causing the standard library's Path API to ignore path componen"}