{"action":"Upgrade node-qs to 6.14.1+ds+~6.14.0-1 or later.","affected":[{"fixed":"6.14.1+ds+~6.14.0-1","introduced":"0"}],"component":"node-qs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["6.14.1+ds+~6.14.0-1"],"id":"tcs_01M5NMZ2NKXEGHPYWBBQT7J3GF","modified_at":"2026-10-15T09:47:44.335825014Z","published_at":"2025-12-29T23:15:42.703Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-15284","https://security-tracker.debian.org/tracker/CVE-2025-15284"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-15284#Debian:14/node-qs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-15284"}],"summary":"Improper Input Validation vulnerability in qs (parse modules) allows HTTP DoS.This issue affects qs: < 6.14.1. Summary The arrayLimit option in qs did not enforce limits for bracket notation (a[]=1&a["}