{"action":"Upgrade geshi to 1.0.8.4-2 or later.","affected":[{"fixed":"1.0.8.4-2","introduced":"0"}],"component":"geshi","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.0.8.4-2"],"id":"tcs_01M5NMZZKRTG1T6NG934WEFAT6","modified_at":"2026-09-01T20:05:41.722418084Z","published_at":"2025-03-09T15:15:36.413Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-2123","https://security-tracker.debian.org/tracker/CVE-2025-2123"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-2123#Debian:13/geshi","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-2123"}],"summary":"A vulnerability, which was classified as problematic, has been found in GeSHi up to 1.0.9.1. Affected by this issue is the function get_var of the file /contrib/cssgen.php of the component CSS Handler"}