{"action":"Upgrade libfcgi to 2.4.5-0.1 or later.","affected":[{"fixed":"2.4.5-0.1","introduced":"0"}],"component":"libfcgi","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.4.5-0.1"],"id":"tcs_01M5NN5MH35NR7KGTCD3RWKXPE","modified_at":"2026-09-01T20:05:44.380872799Z","published_at":"2025-01-10T12:15:25.480Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-23016","https://security-tracker.debian.org/tracker/CVE-2025-23016"],"severity":{"label":"critical","score":9.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-23016#Debian:13/libfcgi","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-23016"}],"summary":"FastCGI fcgi2 (aka fcgi) 2.x through 2.4.4 has an integer overflow (and resultant heap-based buffer overflow) via crafted nameLen or valueLen values in data to the IPC socket. This occurs in ReadParam"}