{"action":"Upgrade ruby-rack to 2.2.13-1~deb12u1 or later.","affected":[{"fixed":"2.2.13-1~deb12u1","introduced":"0"}],"component":"ruby-rack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.2.13-1~deb12u1"],"id":"tcs_01M5NN79NW0K7HT7QAFYXNNEWZ","modified_at":"2026-09-01T20:05:44.688124440Z","published_at":"2025-02-12T17:15:24Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-25184","https://security-tracker.debian.org/tracker/CVE-2025-25184"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-25184","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-25184"}],"summary":"Rack provides an interface for developing web applications in Ruby. Prior to versions 2.2.11, 3.0.12, and 3.1.10, Rack::CommonLogger can be exploited by crafting input that includes newline characters"}