{"action":"Upgrade ruby-graphql to 2.2.17-1 or later.","affected":[{"fixed":"2.2.17-1","introduced":"0"}],"component":"ruby-graphql","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.2.17-1"],"id":"tcs_01M5NN8A3QEFFVZ0S6KWC2TKJ9","modified_at":"2026-09-01T20:05:45.669728838Z","published_at":"2025-03-12T19:15:40.597Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-27407","https://security-tracker.debian.org/tracker/CVE-2025-27407"],"severity":{"label":"critical","score":9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-27407#Debian:13/ruby-graphql","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-27407"}],"summary":"graphql-ruby is a Ruby implementation of GraphQL. Starting in version 1.11.5 and prior to versions 1.11.8, 1.12.25, 1.13.24, 2.0.32, 2.1.14, 2.2.17, and 2.3.21, loading a malicious schema definition i"}