{"action":"Upgrade sqlite3 to 3.46.1-3 or later.","affected":[{"fixed":"3.46.1-3","introduced":"0"}],"component":"sqlite3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.46.1-3"],"id":"tcs_01M5NN8VE29R0WPSW4AF7YNMFC","modified_at":"2026-10-15T09:47:43.289230840Z","published_at":"2025-04-07T20:15:20.253Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-29087","https://security-tracker.debian.org/tracker/CVE-2025-29087"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-29087#Debian:14/sqlite3","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-29087"}],"summary":"In SQLite 3.44.0 through 3.49.0 before 3.49.1, the concat_ws() SQL function can cause memory to be written beyond the end of a malloc-allocated buffer. If the separator argument is attacker-controlled"}