{"action":"Upgrade haproxy to 3.0.10-1 or later.","affected":[{"fixed":"3.0.10-1","introduced":"0"}],"component":"haproxy","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.0.10-1"],"id":"tcs_01M5NNASW8NQRNV5RRS2KTYM9N","modified_at":"2026-09-01T20:05:45.967250993Z","published_at":"2025-04-09T03:15:16.847Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-32464","https://security-tracker.debian.org/tracker/CVE-2025-32464"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-32464#Debian:14/haproxy","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-32464"}],"summary":"HAProxy 2.2 through 3.1.6, in certain uncommon configurations, has a sample_conv_regsub heap-based buffer overflow because of mishandling of the replacement of multiple short patterns with a longer on"}