{"action":"Upgrade proxychains-ng to 4.17-3.1 or later.","affected":[{"fixed":"4.17-3.1","introduced":"0"}],"component":"proxychains-ng","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.17-3.1"],"id":"tcs_01M5NNBDAFWJV7176FT2MH559E","modified_at":"2026-09-01T20:05:46.389296402Z","published_at":"2025-12-18T22:15:56.320Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-34451","https://security-tracker.debian.org/tracker/CVE-2025-34451"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-34451#Debian:14/proxychains-ng","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-34451"}],"summary":"rofl0r/proxychains-ng versions up to and including 4.17 and prior to commit cc005b7 contain a stack-based buffer overflow vulnerability in the function proxy_from_string() located in src/libproxychain"}