{"action":"Upgrade libwww-oauth-perl to 1.001-1 or later.","affected":[{"fixed":"1.001-1","introduced":"0"}],"component":"libwww-oauth-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.001-1"],"id":"tcs_01M5NNVN2J6CZAQ17DV2NVEBYR","modified_at":"2026-09-01T20:05:52.797733874Z","published_at":"2026-02-13T00:16:03.280Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-40905","https://security-tracker.debian.org/tracker/CVE-2025-40905"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-40905#Debian:13/libwww-oauth-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-40905"}],"summary":"WWW::OAuth 1.000 and earlier for Perl uses the rand() function as the default source of entropy, which is not cryptographically secure, for cryptographic functions."}