{"action":"Upgrade libcryptx-perl to 0.066-1 or later.","affected":[{"fixed":"0.066-1","introduced":"0"}],"component":"libcryptx-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.066-1"],"id":"tcs_01M5NNVQPVFBVDZ2S0TR27CTRT","modified_at":"2026-09-01T20:05:52.190292454Z","published_at":"2025-06-11T18:15:25.550Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-40912","https://security-tracker.debian.org/tracker/CVE-2025-40912"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-40912#Debian:13/libcryptx-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-40912"}],"summary":"CryptX for Perl before version 0.065 contains a dependency that may be susceptible to malformed unicode. CryptX embeds the tomcrypt library. The versions of that library in CryptX before 0.065 may be"}