{"action":"Upgrade libjson-xs-perl to 4.030-3 or later.","affected":[{"fixed":"4.030-3","introduced":"0"}],"component":"libjson-xs-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.030-3"],"id":"tcs_01M5NNVTHMTHB2P2365BJHRMV0","modified_at":"2026-09-01T20:05:52.643001682Z","published_at":"2025-09-08T15:15:35.810Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-40928","https://security-tracker.debian.org/tracker/CVE-2025-40928"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-40928#Debian:14/libjson-xs-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-40928"}],"summary":"JSON::XS before version 4.04 for Perl has an integer buffer overflow causing a segfault when parsing crafted JSON, enabling denial-of-service attacks or other unspecified impact"}