{"action":"Upgrade quickjs to 2025.04.26-1 or later.","affected":[{"fixed":"2025.04.26-1","introduced":"0"}],"component":"quickjs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2025.04.26-1"],"id":"tcs_01M5NNXS2E63KY8D7VVTX7H77W","modified_at":"2026-09-01T20:05:52.762540974Z","published_at":"2025-04-27T20:15:15.877Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-46688","https://security-tracker.debian.org/tracker/CVE-2025-46688"],"severity":{"label":"high","score":8.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-46688#Debian:14/quickjs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-46688"}],"summary":"quickjs-ng through 0.9.0 has an incorrect size calculation in JS_ReadBigInt for a BigInt, leading to a heap-based buffer overflow. QuickJS before 2025-04-26 is also affected."}