{"action":"Upgrade ruby-rack to 3.1.16-0.1 or later.","affected":[{"fixed":"3.1.16-0.1","introduced":"0"}],"component":"ruby-rack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.1.16-0.1"],"id":"tcs_01M5NNZ210XBYCWEPZS8X7TD8W","modified_at":"2026-09-01T20:05:53.171777073Z","published_at":"2025-06-04T23:15:21.540Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-49007","https://security-tracker.debian.org/tracker/CVE-2025-49007"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-49007#Debian:14/ruby-rack","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-49007"}],"summary":"Rack is a modular Ruby web server interface. Starting in version 3.1.0 and prior to version 3.1.16, there is a denial of service vulnerability in the Content-Disposition parsing component of Rack. Thi"}