{"action":"Upgrade squid to 6.5-1 or later.","affected":[{"fixed":"6.5-1","introduced":"0"}],"component":"squid","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["6.5-1"],"id":"tcs_01M5NP1V0Y86E2WCKD2S2VJACD","modified_at":"2026-09-01T20:05:54.580853077Z","published_at":"2025-08-01T18:15:55.390Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-54574","https://security-tracker.debian.org/tracker/CVE-2025-54574"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-54574#Debian:14/squid","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-54574"}],"summary":"Squid is a caching proxy for the Web. In versions 6.3 and below, Squid is vulnerable to a heap buffer overflow and possible remote code execution attack when processing URN due to incorrect buffer man"}