{"action":"Upgrade firebird4.0 to 4.0.6.3221.ds6-1 or later.","affected":[{"fixed":"4.0.6.3221.ds6-1","introduced":"0"}],"component":"firebird4.0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.0.6.3221.ds6-1"],"id":"tcs_01M5NP20AP2C8ZQ2HE7KMDADZA","modified_at":"2026-09-01T20:05:54.616738006Z","published_at":"2025-08-15T15:15:32.597Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-54989","https://security-tracker.debian.org/tracker/CVE-2025-54989"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-54989#Debian:14/firebird4.0","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-54989"}],"summary":"Firebird is a relational database. Prior to versions 3.0.13, 4.0.6, and 5.0.3, there is an XDR message parsing NULL pointer dereference denial-of-service vulnerability in Firebird. This specific flaw"}