{"action":"Upgrade cjson to 1.7.19-1 or later.","affected":[{"fixed":"1.7.19-1","introduced":"0"}],"component":"cjson","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.7.19-1"],"id":"tcs_01M5NP2M6DTC7KZ9PRH7J8GCXK","modified_at":"2026-09-01T20:05:54.627347389Z","published_at":"2025-09-03T15:15:38.250Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-57052","https://security-tracker.debian.org/tracker/CVE-2025-57052"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-57052#Debian:14/cjson","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-57052"}],"summary":"cJSON 1.5.0 through 1.7.18 allows out-of-bounds access via the decode_array_index_from_pointer function in cJSON_Utils.c, allowing remote attackers to bypass array bounds checking and access restricte"}