{"action":"Upgrade python-internetarchive to 3.3.0-2~deb12u1 or later.","affected":[{"fixed":"3.3.0-2~deb12u1","introduced":"0"}],"component":"python-internetarchive","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["3.3.0-2~deb12u1"],"id":"tcs_01M5NP348CE5DNK6X1H8AGMS9F","modified_at":"2026-09-01T20:05:55.093303163Z","published_at":"2025-09-06T19:15:38.533Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-58438","https://security-tracker.debian.org/tracker/CVE-2025-58438"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-58438","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-58438"}],"summary":"internetarchive is a Python and Command-Line Interface to Archive.org In versions 5.5.0 and below, there is a directory traversal (path traversal) vulnerability in the File.download() method of the in"}