{"action":"Upgrade zookeeper to 3.9.4-1 or later.","affected":[{"fixed":"3.9.4-1","introduced":"0"}],"component":"zookeeper","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.9.4-1"],"id":"tcs_01M5NP34Q20W6H2ZPM63NTZ4ZW","modified_at":"2026-09-01T20:05:54.524091534Z","published_at":"2025-09-24T10:15:28.020Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-58457","https://security-tracker.debian.org/tracker/CVE-2025-58457"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-58457#Debian:14/zookeeper","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-58457"}],"summary":"Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions. This issue affects Apache ZooKeeper: from 3.9.0 before 3.9"}