{"action":"Upgrade node-tar-fs to 3.0.9+~cs2.0.4-2 or later.","affected":[{"fixed":"3.0.9+~cs2.0.4-2","introduced":"0"}],"component":"node-tar-fs","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.0.9+~cs2.0.4-2"],"id":"tcs_01M5NP3D8CBAXH3XBYMVESXC2G","modified_at":"2026-09-01T20:05:54.686185038Z","published_at":"2025-09-24T18:15:42.297Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-59343","https://security-tracker.debian.org/tracker/CVE-2025-59343"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-59343#Debian:14/node-tar-fs","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-59343"}],"summary":"tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.1.1, 2.1.3, and 1.16.5 are vulnerable to symlink validation bypass if the destination directory is predictable with a specific t"}