{"action":"Upgrade ruby-rack to 3.0.8-2 or later.","affected":[{"fixed":"3.0.8-2","introduced":"0"}],"component":"ruby-rack","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.0.8-2"],"id":"tcs_01M5NP3SCQAYBS11YYKR5N98A2","modified_at":"2026-10-23T17:47:42.782770284Z","published_at":"2025-09-25T15:16:13.780Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-59830","https://security-tracker.debian.org/tracker/CVE-2025-59830"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-59830#Debian:14/ruby-rack","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-59830"}],"summary":"Rack is a modular Ruby web server interface. Prior to version 2.2.18, Rack::QueryParser enforces its params_limit only for parameters separated by &, while still splitting on both & and ;. As a result"}