{"action":"Upgrade vega.js to 5.33.1+ds+~cs5.3.0-4 or later.","affected":[{"fixed":"5.33.1+ds+~cs5.3.0-4","introduced":"0"}],"component":"vega.js","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.33.1+ds+~cs5.3.0-4"],"id":"tcs_01M5NP3SQDK9NH2NJGNQ7MM3T2","modified_at":"2026-10-23T17:47:27.513166500Z","published_at":"2025-11-13T20:15:51.210Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-59840","https://security-tracker.debian.org/tracker/CVE-2025-59840"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-59840#Debian:14/vega.js","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-59840"}],"summary":"Vega is a visualization grammar, a declarative format for creating, saving, and sharing interactive visualization designs. In Vega prior to version 6.2.0, applications meeting 2 conditions are at risk"}