{"action":"Upgrade cpp-httplib to 0.41.0+ds-3 or later.","affected":[{"fixed":"0.41.0+ds-3","introduced":"0"}],"component":"cpp-httplib","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.41.0+ds-3"],"id":"tcs_01M5NP75TDX91VTEGK6NH6Z9RC","modified_at":"2026-09-01T20:05:56.240606896Z","published_at":"2025-12-05T19:15:51.923Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-66570","https://security-tracker.debian.org/tracker/CVE-2025-66570"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-66570#Debian:14/cpp-httplib","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-66570"}],"summary":"cpp-httplib is a C++11 single-file header-only cross platform HTTP/HTTPS library. Prior to 0.27.0, a vulnerability allows attacker-controlled HTTP headers to influence server-visible metadata, logging"}