{"action":"Upgrade tomcat9 to 9.0.70-2 or later.","affected":[{"fixed":"9.0.70-2","introduced":"0"}],"component":"tomcat9","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["9.0.70-2"],"id":"tcs_01M5NP76Y5M7B8XSB3XTGXR3SH","modified_at":"2026-09-01T20:04:29.456171852Z","published_at":"2026-02-17T19:21:55.310Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-66614","https://security-tracker.debian.org/tracker/CVE-2025-66614"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-66614#Debian:12/tomcat9","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-66614"}],"summary":"Improper Input Validation vulnerability. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.14, from 10.1.0-M1 through 10.1.49, from 9.0.0-M1 through 9.0.112. The following versions were EO"}