{"action":"Upgrade weasyprint to 69.0-1 or later.","affected":[{"fixed":"69.0-1","introduced":"0"}],"component":"weasyprint","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["69.0-1"],"id":"tcs_01M5NP9WSVM54JZD2PQXMXZ5XZ","modified_at":"2026-09-01T20:05:57.496417862Z","published_at":"2026-01-19T16:15:53.573Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-68616","https://security-tracker.debian.org/tracker/CVE-2025-68616"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-68616#Debian:14/weasyprint","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-68616"}],"summary":"WeasyPrint helps web developers to create PDF documents. Prior to version 68.0, a server-side request forgery (SSRF) protection bypass exists in WeasyPrint's `default_url_fetcher`. The vulnerability a"}