{"action":"Upgrade mruby to 3.4.0-2 or later.","affected":[{"fixed":"3.4.0-2","introduced":"0"}],"component":"mruby","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.4.0-2"],"id":"tcs_01M5NPDCQE8B61TAGKK5DCTWV9","modified_at":"2026-09-01T20:05:58.911424108Z","published_at":"2025-07-09T01:15:50.380Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-7207","https://security-tracker.debian.org/tracker/CVE-2025-7207"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-7207#Debian:14/mruby","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-7207"}],"summary":"A vulnerability, which was classified as problematic, was found in mruby up to 3.4.0-rc2. Affected is the function scope_new of the file mrbgems/mruby-compiler/core/codegen.c of the component nregs Ha"}