{"action":"Upgrade node-on-headers to 1.0.2-4 or later.","affected":[{"fixed":"1.0.2-4","introduced":"0"}],"component":"node-on-headers","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.0.2-4"],"id":"tcs_01M5NPDD29D6MYDV2W15JJP05N","modified_at":"2026-09-01T20:05:59.417262482Z","published_at":"2025-07-17T16:15:35.403Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-7339","https://security-tracker.debian.org/tracker/CVE-2025-7339"],"severity":{"label":"low","score":3.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-7339#Debian:14/node-on-headers","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-7339"}],"summary":"on-headers is a node.js middleware for listening to when a response writes headers. A bug in on-headers versions `<1.1.0` may result in response headers being inadvertently modified when an array is p"}