{"action":"Upgrade tcpreplay to 4.5.2-1 or later.","affected":[{"fixed":"4.5.2-1","introduced":"0"}],"component":"tcpreplay","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.5.2-1"],"id":"tcs_01M5NPEG4VX8G26DFG63T67MK0","modified_at":"2026-09-01T20:05:59.110259095Z","published_at":"2025-08-19T20:15:37.310Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2025-9157","https://security-tracker.debian.org/tracker/CVE-2025-9157"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2025-9157#Debian:14/tcpreplay","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2025-9157"}],"summary":"A vulnerability was determined in appneta tcpreplay up to 4.5.2-beta2. The impacted element is the function untrunc_packet of the file src/tcpedit/edit_packet.c of the component tcprewrite. Executing"}