{"action":"Upgrade node-brace-expansion to 2.1.7+~1.1.2-1 or later.","affected":[{"fixed":"2.1.7+~1.1.2-1","introduced":"0"}],"component":"node-brace-expansion","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.1.7+~1.1.2-1"],"id":"tcs_01M5NPJX9T5P1CWFNVSBD9SGF8","modified_at":"2026-10-09T17:00:11.465201275Z","published_at":"2026-09-28T21:17:16.300Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-102277","https://security-tracker.debian.org/tracker/CVE-2026-102277"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-102277#Debian:14/node-brace-expansion","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-102277"}],"summary":"The brace-expansion library generates arbitrary strings containing a common prefix and suffix. Prior to 1.1.21, 2.1.7, 3.0.9, and 5.0.12, the expand function handles untrusted {a},b}-shaped patterns w"}