{"action":"Upgrade libdancer2-perl to 2.2.2-1 or later.","affected":[{"fixed":"2.2.2-1","introduced":"0"}],"component":"libdancer2-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.2.2-1"],"id":"tcs_01M5NQFGX72D6YKKZYTTPR0WWW","modified_at":"2026-10-25T09:47:31.382494356Z","published_at":"2026-07-20T08:16:28.987Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-13577","https://security-tracker.debian.org/tracker/CVE-2026-13577"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-13577#Debian:14/libdancer2-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-13577"}],"summary":"Dancer2 versions before 2.2.0 for Perl generate insecure session ids when required CSPRNG modules are unavailable. Dancer2::Core::Role::SessionFactory::generate_id silently falls back to a built-in ra"}