{"action":"Upgrade libcrypt-urandom-perl to 0.55-1 or later.","affected":[{"fixed":"0.55-1","introduced":"0"}],"component":"libcrypt-urandom-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.55-1"],"id":"tcs_01M5NR4KTKFV8KH16KP9RX7E8P","modified_at":"2026-10-01T03:03:21.690026483Z","published_at":"2026-02-16T21:22:18.107Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-2474","https://security-tracker.debian.org/tracker/CVE-2026-2474"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-2474#Debian:14/libcrypt-urandom-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-2474"}],"summary":"Crypt::URandom versions from 0.41 before 0.55 for Perl is vulnerable to a heap buffer overflow in the XS function crypt_urandom_getrandom(). The function does not validate that the length parameter is"}