{"action":"Upgrade nats-server to 2.12.6-1 or later.","affected":[{"fixed":"2.12.6-1","introduced":"0"}],"component":"nats-server","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.12.6-1"],"id":"tcs_01M5NRG2JGHCKMZRNMHX64SC87","modified_at":"2026-10-01T03:03:07.923511563Z","published_at":"2026-03-25T20:16:27.210Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-27889","https://security-tracker.debian.org/tracker/CVE-2026-27889"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-27889#Debian:14/nats-server","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-27889"}],"summary":"NATS-Server is a High-Performance server for NATS.io, a cloud and edge native messaging system. Starting in version 2.2.0 and prior to versions 2.11.14 and 2.12.5, a missing sanity check on a WebSocke"}