{"action":"Upgrade pgvector to 0.8.2-1 or later.","affected":[{"fixed":"0.8.2-1","introduced":"0"}],"component":"pgvector","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.8.2-1"],"id":"tcs_01M5NRN2RYZZBK303S82FS4JK9","modified_at":"2026-10-01T03:02:36.820093980Z","published_at":"2026-02-25T21:16:44.857Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-3172","https://security-tracker.debian.org/tracker/CVE-2026-3172"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-3172#Debian:14/pgvector","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-3172"}],"summary":"Buffer overflow in parallel HNSW index build in pgvector 0.6.0 through 0.8.1 allows a database user to leak sensitive data from other relations or crash the database server."}