{"action":"Upgrade xrdp to 0.9.21.1-1+deb12u3 or later.","affected":[{"fixed":"0.9.21.1-1+deb12u3","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.21.1-1+deb12u3"],"id":"tcs_01M5NRPAYQH7VMDFHPFXCK77CY","modified_at":"2026-10-27T09:47:42.657921733Z","published_at":"2026-04-17T20:16:33.953Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-32623","https://security-tracker.debian.org/tracker/CVE-2026-32623"],"severity":{"label":"high","score":8.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-32623","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-32623"}],"summary":"xrdp is an open source RDP server. Versions through 0.10.5 contain a heap-based buffer overflow vulnerability in the NeutrinoRDP module. When proxying RDP sessions from xrdp to another server, the mod"}