{"action":"Upgrade libvncserver to 0.9.15+dfsg-3 or later.","affected":[{"fixed":"0.9.15+dfsg-3","introduced":"0"}],"component":"libvncserver","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.9.15+dfsg-3"],"id":"tcs_01M5NRPPTXCMMZRXMPXA2HX6CE","modified_at":"2026-10-01T03:03:10.275007253Z","published_at":"2026-03-24T18:16:09.423Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-32854","https://security-tracker.debian.org/tracker/CVE-2026-32854"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-32854#Debian:14/libvncserver","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-32854"}],"summary":"LibVNCServer versions 0.9.15 and prior (fixed in commit dc78dee) contain null pointer dereference vulnerabilities in the HTTP proxy handlers within httpProcessInput() in httpd.c that allow remote atta"}