{"action":"Upgrade xrdp to 0.9.21.1-1+deb12u3 or later.","affected":[{"fixed":"0.9.21.1-1+deb12u3","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.21.1-1+deb12u3"],"id":"tcs_01M5NRQNMGEBYWW5E64ARBN3V2","modified_at":"2026-10-27T09:47:30.410327263Z","published_at":"2026-04-17T20:16:34.723Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-33516","https://security-tracker.debian.org/tracker/CVE-2026-33516"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-33516","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-33516"}],"summary":"xrdp is an open source RDP server. Versions through 0.10.5 contain an out-of-bounds read vulnerability during the RDP capability exchange phase. The issue occurs when memory is accessed before validat"}