{"action":"Upgrade xrdp to 0.10.6-1 or later.","affected":[{"fixed":"0.10.6-1","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.10.6-1"],"id":"tcs_01M5NRQP3ZVR9MQ7JS6RPWX3F6","modified_at":"2026-10-01T03:03:03.611275915Z","published_at":"2026-04-17T20:16:34.723Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-33516","https://security-tracker.debian.org/tracker/CVE-2026-33516"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-33516#Debian:14/xrdp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-33516"}],"summary":"xrdp is an open source RDP server. Versions through 0.10.5 contain an out-of-bounds read vulnerability during the RDP capability exchange phase. The issue occurs when memory is accessed before validat"}