{"action":"Upgrade kitty to 0.47.0-1 or later.","affected":[{"fixed":"0.47.0-1","introduced":"0"}],"component":"kitty","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.47.0-1"],"id":"tcs_01M5NRR340JZPCTRQ85ZV1C97D","modified_at":"2026-10-01T03:03:10.477985995Z","published_at":"2026-05-19T19:16:49.293Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-33642","https://security-tracker.debian.org/tracker/CVE-2026-33642"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-33642#Debian:14/kitty","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-33642"}],"summary":"Kitty is a cross-platform GPU based terminal. In versions 0.46.2 and below, the handle_compose_command() function in kitty/graphics.c performs bounds validation on composition offsets using unsigned 3"}