{"action":"Upgrade xrdp to 0.10.6-1 or later.","affected":[{"fixed":"0.10.6-1","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.10.6-1"],"id":"tcs_01M5NRR49D4YGA1AXVP8JGMV4M","modified_at":"2026-10-27T09:47:32.127128960Z","published_at":"2026-04-17T21:16:32.963Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-33689","https://security-tracker.debian.org/tracker/CVE-2026-33689"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-33689#Debian:14/xrdp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-33689"}],"summary":"xrdp is an open source RDP server. Versions through 0.10.5 have an out-of-bounds read vulnerability in the pre-authentication RDP message parsing logic. A remote, unauthenticated attacker can trigger"}