{"action":"Upgrade xrdp to 0.10.1-3.1+deb13u2 or later.","affected":[{"fixed":"0.10.1-3.1+deb13u2","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["0.10.1-3.1+deb13u2"],"id":"tcs_01M5NRV76DQGK715V27APAP3K0","modified_at":"2026-10-01T03:03:10.970243136Z","published_at":"2026-04-17T21:16:33.297Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-35512","https://security-tracker.debian.org/tracker/CVE-2026-35512"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-35512","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-35512"}],"summary":"xrdp is an open source RDP server. Versions through 0.10.5 have a heap-based buffer overflow in the EGFX (graphics dynamic virtual channel) implementation due to insufficient validation of client-cont"}