{"action":"Upgrade rust-gix-submodule to 0.30.0-1 or later.","affected":[{"fixed":"0.30.0-1","introduced":"0"}],"component":"rust-gix-submodule","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.30.0-1"],"id":"tcs_01M5NRX5F1M0TMGFQB9KSBX086","modified_at":"2026-10-09T09:47:24.524870820Z","published_at":"2026-05-26T15:16:35.087Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-40034","https://security-tracker.debian.org/tracker/CVE-2026-40034"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-40034#Debian:14/rust-gix-submodule","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-40034"}],"summary":"gix-submodule before 0.29.0 (gitoxide before 0.5.21, gix before 0.84.0) incorrectly validates the update field in .gitmodules, allowing attackers to bypass the CommandForbiddenInModulesConfiguration g"}