{"action":"Upgrade composer to 2.5.5-1+deb12u4 or later.","affected":[{"fixed":"2.5.5-1+deb12u4","introduced":"0"}],"component":"composer","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["2.5.5-1+deb12u4"],"id":"tcs_01M5NRX9S65V70DWZHPEMMDYAY","modified_at":"2026-10-01T03:02:39.301928283Z","published_at":"2026-04-15T21:17:27.357Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-40176","https://security-tracker.debian.org/tracker/CVE-2026-40176"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-40176","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-40176"}],"summary":"Composer is a dependency manager for PHP. Versions 1.0 through 2.2.26 and 2.3 through 2.9.5 contain a command injection vulnerability in the Perforce::generateP4Command() method, which constructs shel"}