{"action":"Upgrade firebird3.0 to 3.0.14.ds7-1 or later.","affected":[{"fixed":"3.0.14.ds7-1","introduced":"0"}],"component":"firebird3.0","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.0.14.ds7-1"],"id":"tcs_01M5NRXRJFCCQZEMRFXH2GB034","modified_at":"2026-10-27T09:47:29.850446865Z","published_at":"2026-04-17T20:16:35.930Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-40342","https://security-tracker.debian.org/tracker/CVE-2026-40342"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-40342#Debian:14/firebird3.0","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-40342"}],"summary":"Firebird is an open-source relational database management system. In versions prior to 5.0.4, 4.0.7 and 3.0.14, the external engine plugin loader concatenates a user-supplied engine name into a filesy"}