{"action":"Upgrade golang-github-xenolf-lego to 4.35.2-1 or later.","affected":[{"fixed":"4.35.2-1","introduced":"0"}],"component":"golang-github-xenolf-lego","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["4.35.2-1"],"id":"tcs_01M5NRY0JTQBMNVB9SDBREXB56","modified_at":"2026-10-27T09:47:35.058543717Z","published_at":"2026-04-21T18:16:52.457Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-40611","https://security-tracker.debian.org/tracker/CVE-2026-40611"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-40611#Debian:14/golang-github-xenolf-lego","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-40611"}],"summary":"Let's Encrypt client and ACME library written in Go (Lego). Prior to 4.34.0, the webroot HTTP-01 challenge provider in lego is vulnerable to arbitrary file write and deletion via path traversal. A mal"}