{"action":"Upgrade apache-opennlp to 2.5.9-1 or later.","affected":[{"fixed":"2.5.9-1","introduced":"0"}],"component":"apache-opennlp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.5.9-1"],"id":"tcs_01M5NRY1YQ48RMWPM59AWXT9C5","modified_at":"2026-10-27T09:47:43.445216346Z","published_at":"2026-05-04T17:16:23.657Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-40682","https://security-tracker.debian.org/tracker/CVE-2026-40682"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-40682#Debian:14/apache-opennlp","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-40682"}],"summary":"XML External Entity (XXE) via Unsanitized Dictionary Parsing in Apache OpenNLP DictionaryEntryPersistor Versions Affected: before 2.5.9, before 3.0.0-M3 Description: The DictionaryEntryPersistor class"}