{"action":"Upgrade poetry to 2.1.2+dfsg-1 or later.","affected":[{"fixed":"2.1.2+dfsg-1","introduced":"0"}],"component":"poetry","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["2.1.2+dfsg-1"],"id":"tcs_01M5NRYE4E9035HYJSZY8TKA8Z","modified_at":"2026-10-01T03:03:22.769623782Z","published_at":"2026-04-24T18:16:28.613Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-41140","https://security-tracker.debian.org/tracker/CVE-2026-41140"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-41140#Debian:13/poetry","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-41140"}],"summary":"Poetry is a dependency manager for Python. Prior to 2.3.4, the extractall() function in src/poetry/utils/helpers.py:410-426 extracts sdist tarballs without path traversal protection on Python versions"}