{"action":"Upgrade xrdp to 0.9.21.1-1+deb12u3 or later.","affected":[{"fixed":"0.9.21.1-1+deb12u3","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.21.1-1+deb12u3"],"id":"tcs_01M5NRYJ86V3NFWJ5C73S5ZB1C","modified_at":"2026-10-25T09:47:34.932617808Z","published_at":"2026-07-20T17:17:08.310Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-41252","https://security-tracker.debian.org/tracker/CVE-2026-41252"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-41252","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-41252"}],"summary":"xrdp is an open source RDP server. Versions 0.10.6 and prior contain a missing bounds check in xrdp, which allows a heap-based buffer overflow when operating in vnc-any mode. The issue occurs during t"}